When stupidity becomes tradition

“People are never happy.”

This being used as a convenient excuse for an idiotic choice irritates me in ways you cannot conceive. If you want to make boneheaded choices at least have the courage to stand behind them, rather than abstain from responsibility and ascribe them to whims outside your control.

(thanks to “embeddedt” but that fight is beyond pointless, it’s like raging at the wind)

I don’t have dev access to this specific chat, but I would have replied if I could:

This part here is factually wrong. And because so, it’s worth discussing.

“I don’t know what versions people would even want us to target”

The whole discussion above is disingenuous. Yet, let’s pretend it’s not, and that this line is plain honest and it means what it states.

Not only I can tell you “what version people want you to target”, but I can tell you why, I can prove it’s not my personal opinion, and I can tell you how to find the answer without me telling you the answer directly. Because it is quite simple, as long one is earnestly looking for it, rather than sifting through excuses.

Of course no one dictates what someone else has to work on. The same reason why there are people, still today, developing mods for Minecraft beta, or 1.4.7, or 1.5.2.
But the argument here is not about what anyone decides to work with, but what “most” people want, in the sense of the overall community.

The root is obvious, and legitimate:

Despite Embeddedt downsizing the problem, the argument is that it takes a huge amount of overhead to maintain multiple versions. But again, no one is arguing devs CHOICES. I’m here arguing MOTIVATIONS. Your choice is “wrong” not because I get to decide for you. But because the motivation YOU OFFERED doesn’t lead logically to that choice. If that’s the motivation, then your choice is WRONG.

And here’s why.

“Most” people play mods through guided experiences we call modpacks. One obviously cannot create modpacks out of thin air. For example 1.20.3 was released just a few hours ago, it’s not viable for modpacks yet (arguably but likely, it never will). Sodium, the topic here, was just released FOR 1.20.3. Who’s going to use it? For sure people who enjoy a mostly vanilla experience will. And that’s likely still lots of people. Just as long you don’t care about the overall modding context.

Again, your choice. But if you don’t want to ignore the overall modding context, then again the answer is obvious. Even if the community is currently at its most splintered state, there are usually two versions that can be considered “active”. The main and the current.

My point is that you don’t have to rely on my opinion, about what’s main and what’s current. But you can simply find out. Then how? By looking at some of the signature mods. If we agreed that most people play modpacks, and that modpacks are good as structured experiences, then most modpacks will use quests, recipe browsers and map mods. These cases aren’t truly useful, because map mods and recipe browsers will try to support every version under the sun rather than making choices, whereas we’re looking for trends. But the main mod most of everyone uses for quest is “FTB Quests”, and this is already a straightforward answer. Current is 1.20.1, main is 1.19.2.

There is a valid argument, for example, for NOT supporting minor versions like 1.19.3/4, and the reason is that you only target main or current. Whoever is on .4, for example, wouldn’t have any real valid argument to not simply jump to current. Whereas there is a valid argument to stay on main: most mods aren’t yet updated. .3/4 have nothing specific to them that makes them valid alternatives. It’s always either main or current.

You can argue that FTB isn’t representative of the community, since it’s still a privately held company pursuing its own interests. But they still have to work with the mods the community delivers. Again, neither you nor they can build a modpack out of thin air. We all needs the mods to exist, and the more ambitious the mod the more cumbersome the technical update required to keep “version chasing”.

That’s why one of the very best “signature” mods is Botania. It always gets ported to the latest versions, but it’s slow doing so. And again, we get the answer we expect: 1.20.1 is current, 1.19.2 is main. The most recent version was released just a couple of weeks ago. That version became current, in the sense of being viable for a decent modpack in a similar timeframe. Despite 1.20.1 still lacking lots of stuff, and making 1.19.2 still “main.”

A couple of days ago I tried to put together a “modpack” for 1.20.2 neoforge, because if in the future I’m going to deal with that, then I could already have an instance ready to experiment with. This is what I got after searching for a while:

Yep, that’s all.
There would be Journeymap, but I prefer Xaero. That’s all I found (not even a recipe browser available).

It goes without saying (yet it never does), that 1.21 will be out in the next few months, that Mojang shuffled too many technical things in minor .2 and .3 versions, and that Neoforge itself is a more radical departure from .2 onward.

All these together mean that 1.21 will arrive before even a small portions of (significant) mods will be available for any 1.20.2+.

Therefore it is very much plausible and probable that the next “current” version will be 1.21.x, that any 1.20.2+ will be just technical exercises, and that there won’t even be enough time to transform 1.20.1 into “main.” The main version will jump from 1.19.2 to 1.21.x. The technical challenge to move to 1.21 will likely dilute the quality of mods even further. If 1.20 becomes main, it will be as a kind of flux, or no man’s land. Something we call main because there are no better alternatives. Rather than making 1.20.1 reach standard, it will be that the standard itself got lowered.

The community will splinter further.

P.S.
In the context of Sodium, here, the premise is slightly different since Sodium is also used by vanilla players, not just modded. If we assume that Sodium’s “mission” is to version chase, then it is not realistic to expect it not release for any minor version update. 1.20.3 in this case. But since they “conceded to dual-support”, as they say, the argument above is updated, but still valid: 1.20.3 is current, 1.20.1 is main.

If you want to dual support, then you support the “current” (1.20.3 now) and main (1.20.1). That first line above from Embeddedt was right, as long you cut the “personally” it starts with. It’s not personal. It’s simply right.

The reason is that people who don’t care about the available set of mods, the vanilla players, will jump to the most recent. Modded players will stay on 1.20.1.

There isn’t a single valid reason beside internal technicalities to decide to support 1.20.2. It’s not dual-support, it’s useless overhead.

(Since this has been brought up: the tone of my blog is scathing because it’s my blog. I talk to myself. I don’t need euphemisms.)

Follow up.

Leave a Reply